<< Предыдущая

стр. 55
(из 106 стр.)

ОГЛАВЛЕНИЕ

Следующая >>

» Адресные операторы — используются при ссылках на ячейки.
Назначение операторов приведено в таблице 16.1.
Таблица 16.1. Назначение используемых в Excel операторов
Арифметические операторы Назначение операторов
+ (знак плюс) Сложение
Вычитание (или унарный минус, например, -I)
-• (знак минус)
/ (косая черта) Деление
* (звездочка) Умножение
% (знак процента) Процент
" (крышка) Возведение в степень
Операторы сравнения
= (знак равенства) Равно
> (знак больше) Больше
< (зНак меньше) Меньше
>= (знак больше и знак равенства) Больше или равно
<= (знак меньше и знак равенства) Меньше или равно
<> (знак меньше и знак больше) Не равно
Текстовый оператор
& (амперсанд) Объединение двух текстовых строк в одну
Адресные операторы
: (двоеточие) Ссылка на все ячейки между границами диапазона
включительно.
, (запятая) Ссылка на объединение ячеек диапазонов. \
(пробел) Ссылка на общие ячейки диапазонов.


Арифметические операторы
Арифметическими операторы получили наиболее широкое распростране-
ние. Они обеспечивают сложение, вычитание, умножение, деление, возведение
в степень, нахождение процента по данным, приведенным в ячейках электрон-
ной таблицы. Примеры использования арифметических операторов приведены
в таблице 16.2. Предполагается, что в ячейках A l , A2 и A3 содержатся числа 4, 5
и 10 соответственно.
Таблица 16.2. Примеры использования арифметических операторов
Оператор Результат
Пример формулы
+ А1+А2 9
- 1
А2-А1
ж А1*А2 20
/ АЗ/А2 2 |
Выполнение расчетов по формулам в Excel 2003 301

Пример формулы Результат
Оператор
л
16
Л
А1 2
Л
% 8
23

Excel выполняет вычисления в формулах слева направо и соблюдает приня-
тый в математике приоритет выполнения арифметических операций. Первыми
выполняются операции возведения в степень, затем умножение и деление,
в последнюю очередь сложение и вычитание, для изменения порядка выполне-
ния операций используются скобки.
Скобки должны быть парными, пробелы перед скобками или после них не
допускаются, например:
=(АЗ+15)/В4,
где A3, В4 — ссылки на ячейки,
15 — числовая константа,
«+» и «/» — операторы сложения и деления.
Операции в скобках выполняются первыми. Например, в формуле
=(А1+А2+АЗ)/3 сначала вычисляется сумма чисел, содержащихся в ячейках
Al, A2 и A3, потом найденная сумма делится на 3, в то время как в формуле
=А1+А2+АЗ/3 на 3 делится только последнее слагаемое, а не вся сумма. Внутри
скобок можно помещать другие скобки, что называется вложением скобок.


Ввод формулы в ячейку
Для ввода формулы в ячейку выделите ее и введите в строку формул или
в ячейку знак «=».

Запомните
ея как средство, позволяющее создавать и изменять
Строка формул И
форму лы.

При переходе в режим ввода формул поле Имя (Name), расположенное в ле-
вой части строки формул, заменяется кнопкой, на которой отображена послед-
Рис. 16.1
Окно Excel в режиме ввода формул




OS
УГ-М
ТЗНД4
ели
UK-PC сылк А
:МЕТ
МАК:
;УМЧЕСЛИ
плт
Другие фу*ции..
Глава 16
302

няя использовавшаяся функция. Расположенная справа от нее кнопка со
стрелкой открывает список, который содержит 10 последних использовавших-
ся функций и пункт Другие функции (More/unctions) (рис. 16,1).
В качестве примера введем формулу в ячейку D4. Закончив ввод формулы,
нажмем клавишу Enter или щелкнем в строке формул по кнопке Ввод (Enter).
В ячейке, содержащей формулу, отобразится результат вычисления, сама фор-
мула будет видна в строке формул (рис. 16.2).

Рис. 16.2
Отображение расчетной формулы
в строке формул




Использование ссыпок в формуле
Формула может содержать ссылку на ячейку (ее адрес) или на диапазон яче-
ек, а также на имена, представляющие ячейки или диапазоны ячеек. Для опи-
сания ссылок на диапазоны ячеек используются операторы, приведенные
в таблице 16.3.
Таблица 16.3. Операторы ссылки
Операторы ссылки Значение (пример)
; (двоеточие) Ставится между ссылками на первую и последнюю ячейки
диапазона. Такое сочетание является ссылкой на диапазон (В5:В15).
; (точка с запятой) Оператор объединения. Объединяет несколько ссылок в одну
ссылку (СУММ(В5:В15;О5:О!5)).
(пробел) Оператор пересечения множеств, служит для ссылки на общие
ячейки двух диапазонов (B7:D7 C6:C8).

Чтобы сослаться на диапазон ячеек, введите ссылку на верхнюю левую ячей-
ку диапазона, поставьте двоеточие (:), а затем — ссылку на правый нижний угол
диапазона. Например, А2:С5. Ссылка на все ячейки между 6-й и 15-й строками
включительно имеет вид 6:15, на все ячейки в столбце С — С:С.
Для задания обращения ко всем ячейкам, находящимся в нескольких диапа-
зонах одновременно используется пересечение. Для задания пересечения диа-
пазонов используется пробел. Например, формула =СУММ(А2:ВЗ В2:СЗ) вы-
числяет сумму чисел в пересекающихся диапазонах А2:ВЗ и В2:СЗ. Для обраще-
ния ко всем ячейкам, включенным в два диапазона, используется объединение.
Если в ячейке ВЗ записано Петров, а ячейке A3 -- Владимир, то формула
АЗ—ВЗ&", "&АЗ будет означать объединение указанных выше имен, разделен-
Выполнение расчетов по формулам в Excel 2003 303

ных запятой (Петров, Владимир). При использовании операторов объединения
и пересечения удобно пользоваться именованными диапазонами.
В формулу можно вводить ссылки на ячейки различных рабочих листов
и книг. Ссылки, распространяющиеся на несколько рабочих листов, называют-
ся трехмерными. Ячейка, содержащая формулу, называется зависимой ячей-
кой. Ее значение зависит от значений ячеек, на которые имеются ссылки
в формуле.
Примеры записей диапазонов ячеек в функции:
• =СУММ(Е:Е) — определяется сумма числовых значений, содержащихся
в столбце Е;
• =СУММ(Е2:С5) — подсчитывается сумма числовых значений, располо-
женных в диапазоне от Е2 до G5;
• — СУММ(5:5) — суммируются данные всех ячеек пятой строки;
• =СУММ(2;4) — подсчитывается сумма 2+4.
Допускается смешанная запись адресов ячеек и блоков ячеек. В этом случае
формула может выглядеть следующим образом:
=СУММ(С8;04;Е2:Е5;Р5)

Ввод в формулу ссылок на ячейки с помощью мыши

Запомните
Чтобы избежать-в формуле ошибок при вводе ссылок жз ячейки, .адрес ссылки
:
' можно вбестй щелчком мыши на этой ячейке!'

Так, если вам необходимо после знака = в формуле дать ссылку на ячейку
А4, щелкните на этой ячейке мышью, вокруг ячейки появится бегущая рамка, а
в формуле отобразится ссылка на эту ячейку. Для ввода ссылки на диапазон
ячеек щелкните по угловой ячейке диапазона и, удерживая нажатой кнопку
мыши, перетащите указатель в противоположный угол для выделения всего
диапазона.

Отображение формулы в ячейке
При стандартной настройке в ячейке с формулой отображается результат
вычислений, а не сама формула. В некоторых случаях, например, при составле-
нии и проверки сложных расчетов в ячейке удобнее отображать не числовое
значение, а саму формулу.

Запомните
Для отображения формул .нет рабочем лмсте выберите в меню Сервис команду;..
ПараметрьНОрИопз) в меню Сервис; (Tools) откройте вкладку Вид (Vfevv; и в рам-"
ке Параметру/окна (Window Options) установите флажок формулы (formulas)
' (см.тлаву 19, рис; 19.8).

Для возврата к принятому режиму отображения формул снимите флажок.
Чтобы перейти в режим отображения формул или вернуться в обычный режим
нажмите клавиши Ctrl+' (клавиша обратного апострофа находится на той же
клавише, что и тильда «˜» — ниже клавиши Esc).
Глава 16
304


Подсказки аргументов функций
При создании новой формулы в Excel отображается информация об аргу-
ментах функции. Кроме того, всплывающие подсказки обеспечивают быстрый
доступ к нужным разделам справки. Пользователю достаточно щелкнуть мы-
шью имя любой функции или аргумента, отображаемых во всплывающей под-
сказке.

Абсолютная и относительная ссылка
Ссылка — это указание адреса ячейки. Различают относительные или абсо-
лютные ссылки.

Запомните
Относительные ссылки, используемые в формуле, ^автоматически изменяются .
при копирований формулы в другие ячейки,

Например, нам надо подсчитать сумму чисел, хранящихся в ячейках Al, A2,
A3. Щелкнем дважды ячейку А5, и поместим в нее формулу=А1 +А2+АЗ. Чтобы
вычислить сумму чисел, хранящихся в ячейках Cl, C2, СЗ, можно не писать за-
ново формулу, а скопировать ее из ячейки А5 в С5 (см. главу 14, раздел «Копи-
рование и перемещение содержимого ячеек»). Excel автоматически изменит от-
носительные ссылки и формула примет вид =С1+С2+СЗ. Измененную форму-
лу можно увидеть, щелкнув ячейку С5. (Для отображения формул в окне
приложения установите флажок формулы на вкладке Вид диалогового окна Па-
раметры (рис. 19.8).)

Запомните
Абсолютная.ссылка сохраняет адрес определенной ячейки независимо от ме-
стоположения ячейки с формулой,.

Например, если скопировать формулу из ячейки А7 с абсолютными ссылка-
ми в ячейку С7, то формула не изменится. Для указания абсолютной ссылки
используется знак доллара $. $А$7, $С$7 (рис. 16.3). Адреса ячеек, использо-
ванные в формуле, и границы этих ячеек будут закрашены в одинаковые цвета.

Рис. 16.3 13 Microsoft Excel • КннгэЗ
Отображение формул ид Ветды<э Фрриат Сервис Денное QSH
с абсолютными ,,Y J-' • '- ? X
и относительными ссылками
в окне Excel •
- ю - | Ж Ж Ч, • JK.J Ц л? ! Я •- •:?* -г А -
>,Aria cyr
Выполнение расчетов по формулам в Excel 2003 305

В тех случаях, когда при копировании или перемещении формулы необхо-
димо сохранить неизменным только номер строки или только наименование
столбца, применяют смешанную ссылку, например $D7 или FS5. Более под-
робно использование абсолютной ссылки в формуле рассмотрено ниже в раз-
деле «Копирование формулы».
Внешние и удаленные ссылки
Можно ссылаться на ячейки, находящиеся на других листах книги или
в другой книге, или на данные другого приложения. Ссылки на ячейки других
книг называются внешними ссылками. Ссылки на данные других приложений
называются удаленными ссылками.

;. Запомните
При вводе ссылки: нд ячейку другого рабочего листа имя листа отделяется от
. имени ячейки восклицательным знаком. Если вводится ссылка на другую р?або-;
S;
: .чую книгу, то указывается имя файла рабочей книги, которое заклинается в квад- .
=: --ратныескобки, например, ЕКнига2)Лист1!$С$3.

Смарт-тег проверки ошибок
О возможной ошибке в ячейке пользователя оповещает смарт-тег проверки
ошибок. Пользователю предлагается исправить ошибку, пропустить ее или по-
лучить доступ к дополнительным параметрам средства проверки ошибок. По-
пробуйте вычислить сумму по столбцу, пропустив последнюю ячейку группы.
Наведите указатель на ячейку, содержащую сумму, чтобы отобразились вариан-
ты, предлагаемые функцией проверки ошибок.
Панель аудита формул
Панель аудита формул предлагает ряд элементов управления для доступа
к функциям аудита, таким как средство проверки формул и окно контрольного
значения. Данная функция позволяет выполнить вычисление пд шагам и по-
нять, каким образом получается итоговый результат. Она также предоставляет
некоторые дополнительные возможности, например переключение в режим

<< Предыдущая

стр. 55
(из 106 стр.)

ОГЛАВЛЕНИЕ

Следующая >>